GitHub Advisoryadvisory · Go
GHSA-56wx-66px-9j66 OPKSSH Vulnerable to Authentication Bypass
CRITICAL
Official page ↗
- Aliases
- CVE-2025-4658
- Ecosystem
- Go
- Packages
- github.com/openpubkey/opkssh
- Severity
- Critical
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:L/SI:L/SA:L
- Weaknesses
- CWE-305
- Reviewed
- 2025-05-13
Affected packages
• Go github.com/openpubkey/opkssh: < 0.5.0 → fixed in 0.5.0
Description
Impact
Versions of OpenPubkey library prior to 0.10.0 contained a vulnerability that would allow a specially crafted JWS to bypass signature verification. As OPKSSH depends on the OpenPubkey library for authentication, this vulnerability in OpenPubkey also applies to OPKSSH versions prior to 0.5.0 and would allow an attacker to bypass OPKSSH authentication.
Patches
The vulnerability does not exist in more recent versions of OPKSSH. his only impacts OPKSSH when used to verify ssh keys on a server, the OPKSSH client is unaffected. To remediate upgrade to a version of OPKSSH v0.5.0 or greater.
To determine if you are vulnerable run on your server:
```bash
opkssh --version
```
If the version is less than 0.5.0 you should upgrade. To upgrade to the latest version run:
```bash
wget -qO- "https://raw.githubusercontent.com/openpubkey/opkssh/main/scripts/install-linux.sh" | sudo bash
```
References
CVE-2025-4658
The upstream vulnerability in OpenPubkey is CVE-2025-3757 and has the security advisory https://github.com/openpubkey/openpubkey/security/advisories/GHSA-537f-gxgm-3jjq
Related
Alias · CVE (1)
- CVE-2025-4658 Versions of OpenPubkey library prior to 0.10.0 contained a vulnerability that would allow a specially crafted JWS to bypass signature… vulnerability
Weakness · CWE (1)
- CWE-305 Authentication Bypass by Primary Weakness weakness