GitHub Advisoryadvisory · Packagist

GHSA-5729-822w-j342 Moodle cross-site scripting (XSS) vulnerability

MEDIUM Published 2022-05-13 Modified 2024-01-26 Official page ↗
Aliases
CVE-2015-5269
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2024-01-26

Affected packages

• Packagist moodle/moodle: < 2.7.10 → fixed in 2.7.10 • Packagist moodle/moodle: >= 2.8.0, < 2.8.8 → fixed in 2.8.8 • Packagist moodle/moodle: >= 2.9.0, < 2.9.2 → fixed in 2.9.2

Description

Cross-site scripting (XSS) vulnerability in group/overview.php in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before 2.9.2 allows remote authenticated users to inject arbitrary web script or HTML via a modified grouping description.

Related

Alias · CVE (1)

  • CVE-2015-5269 Cross-site scripting (XSS) vulnerability in group/overview.php in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References