GitHub Advisoryadvisory · PyPI

GHSA-577h-p2hh-v4mv Langflow CORS misconfiguration enables Account Takeover and RCE

CRITICAL Published 2025-12-06 Modified 2026-05-29 Official page ↗
Aliases
CVE-2025-34291
Ecosystem
PyPI
Packages
langflow
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-346
Reviewed
2026-01-21

Affected packages

• PyPI langflow: < 1.7.0 → fixed in 1.7.0

Description

Langflow versions up to and including 1.6.9 contain a chained vulnerability that enables account takeover and remote code execution. An overly permissive CORS configuration (allow_origins='*' with allow_credentials=True) combined with a refresh token cookie configured as SameSite=None allows a malicious webpage to perform cross-origin requests that include credentials and successfully call the refresh endpoint. An attacker-controlled origin can therefore obtain fresh access_token / refresh_token pairs for a victim session. Obtained tokens permit access to authenticated endpoints — including built-in code-execution functionality — allowing the attacker to execute arbitrary code and achieve full system compromise.

Related

Alias · CVE (1)

  • CVE-2025-34291 Langflow versions up to and including 1.6.9 contain a chained vulnerability that enables account takeover and remote code execution. vulnerability

Weakness · CWE (1)

  • CWE-346 Origin Validation Error weakness

References