GitHub Advisoryadvisory · Go
GHSA-5796-p3m6-9qj4 Cloud Foundry Routing Improper Input Validation vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2019-11289
- Ecosystem
- Go
- Packages
- code.cloudfoundry.org/gorouter
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-20
- Reviewed
- 2021-05-17
Affected packages
• Go code.cloudfoundry.org/gorouter: < 0.0.0-20191101214924-b1b5c44e050f → fixed in 0.0.0-20191101214924-b1b5c44e050f
Description
Cloud Foundry Routing, all versions before 0.0.0-20191101214924-b1b5c44e050f, does not properly validate nonce input. A remote unauthorized malicious user could forge a route service request using an invalid nonce that will cause the Gorouter to crash.
Related
Alias · CVE (1)
- CVE-2019-11289 Cloud Foundry Routing, all versions before 0.193.0, does not properly validate nonce input. vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness