GitHub Advisoryadvisory · RubyGems

GHSA-579w-22j4-4749 Denial of Service Vulnerability in ActiveRecord's PostgreSQL adapter

HIGH Published 2023-01-18 Modified 2026-01-15 Official page ↗
Aliases
CVE-2022-44566
Ecosystem
RubyGems
Packages
activerecord
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-400
Reviewed
2023-01-18

Affected packages

• RubyGems activerecord: < 6.1.7.1 → fixed in 6.1.7.1 • RubyGems activerecord: >= 7.0.0, < 7.0.4.1 → fixed in 7.0.4.1

Description

There is a potential denial of service vulnerability present in ActiveRecord's PostgreSQL adapter. This has been assigned the CVE identifier CVE-2022-44566. Versions Affected: All. Not affected: None. Fixed Versions • 2.3.18.47 (Rails LTS, which is a paid service and not part of the rubygem) • 3.2.22.34 (Rails LTS, which is a paid service and not part of the rubygem) • 4.2.11.27 (Rails LTS, which is a paid service and not part of the rubygem) • 5.2.8.15 (Rails LTS, which is a paid service and not part of the rubygem) • 6.1.7.1 • 7.0.4.1 Impact In ActiveRecord < 7.0.4.1 and < 6.1.7.1, when a value outside the range for a 64bit signed integer is provided to the PostgreSQL connection adapter, it will treat the target column type as numeric. Comparing integer values against numeric values can result in a slow sequential scan resulting in potential Denial of Service. Releases The fixed releases are available at the normal locations. Workarounds Ensure that user supplied input which is provided to ActiveRecord clauses do not contain integers wider than a signed 64bit representation or floats. Patches To aid users who aren't able to upgrade immediately we have provided patches for the supported release series in accordance with our maintenance policy 1 regarding security issues. They are in git-am format and consist of a single changeset. 6-1-Added-integer-width-check-to-PostgreSQL-Quoting.patch - Patch for 6.1 series 7-0-Added-integer-width-check-to-PostgreSQL-Quoting.patch - Patch for 7.0 series

Related

Alias · CVE (1)

  • CVE-2022-44566 A denial of service vulnerability present in ActiveRecord's PostgreSQL adapter <7.0.4.1 and <6.1.7.1. vulnerability

Weakness · CWE (1)

  • CWE-400 Uncontrolled Resource Consumption weakness

References