GitHub Advisoryadvisory · PyPI
GHSA-57fc-8q82-gfp3 langchain vulnerable to arbitrary code execution
CRITICAL
Official page ↗
- Aliases
- CVE-2023-36188
- Ecosystem
- PyPI
- Packages
- langchain
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-74
- Reviewed
- 2023-07-06
Affected packages
• PyPI langchain: < 0.0.247 → fixed in 0.0.247
Description
An issue in langchain allows a remote attacker to execute arbitrary code via the PALChain parameter in the Python exec method.
Related
Alias · CVE (1)
- CVE-2023-36188 An issue in langchain v.0.0.64 allows a remote attacker to execute arbitrary code via the PALChain parameter in the Python exec method. vulnerability
Weakness · CWE (1)
- CWE-74 Improper Neutralization of Special Elements in Output Used by a Downstream Component weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2023-36188 advisory
- https://github.com/langchain-ai/langchain/issues/5872 web
- https://github.com/langchain-ai/langchain/pull/6003 web
- https://github.com/langchain-ai/langchain/pull/8425 web
- https://github.com/langchain-ai/langchain/commit/e294ba475a355feb95003ed8f1a2b99942509a9e web
- https://github.com/advisories/GHSA-57fc-8q82-gfp3 advisory
- https://github.com/langchain-ai/langchain package
- https://github.com/pypa/advisory-database/tree/main/vulns/langchain/PYSEC-2023-109.yaml web