GitHub Advisoryadvisory · npm, Maven, Go, NuGet, SwiftURL, RubyGems, crates.io, Packagist, Pub, PyPI

GHSA-5844-q3fc-56rh pubnub Insufficient Entropy vulnerability

MEDIUM Published 2023-12-06 Modified 2025-07-22 Official page ↗
Aliases
CVE-2023-26154
Ecosystem
npm, Maven, Go, NuGet, SwiftURL, RubyGems, crates.io, Packagist, Pub, PyPI
Packages
pubnub, com.pubnub:pubnub-kotlin, com.pubnub:pubnub, github.com/pubnub/go/v7, github.com/pubnub/go, github.com/pubnub/go/v6, github.com/pubnub/go/v5, Pubnub, github.com/pubnub/swift, pubnub/pubnub
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-331
Reviewed
2023-12-06

Affected packages

• npm pubnub: < 7.4.0 → fixed in 7.4.0 • Maven com.pubnub:pubnub-kotlin: < 7.7.0 → fixed in 7.7.0 • Maven com.pubnub:pubnub: <= 4.6.5 (no fix yet) • Go github.com/pubnub/go/v7: < 7.2.0 → fixed in 7.2.0 • Go github.com/pubnub/go: < 0.0.0-20231016150651-428517fef5b9 → fixed in 0.0.0-20231016150651-428517fef5b9 • Go github.com/pubnub/go/v6: < 6.1.1-0.20231016150651-428517fef5b9 → fixed in 6.1.1-0.20231016150651-428517fef5b9 • Go github.com/pubnub/go/v5: < 5.0.4-0.20231016150651-428517fef5b9 → fixed in 5.0.4-0.20231016150651-428517fef5b9 • NuGet Pubnub: < 6.19.0 → fixed in 6.19.0 • SwiftURL github.com/pubnub/swift: < 6.2.0 → fixed in 6.2.0 • RubyGems pubnub: < 5.3.0 → fixed in 5.3.0 • crates.io pubnub: < 0.4.0 → fixed in 0.4.0 • Packagist pubnub/pubnub: < 6.1.0 → fixed in 6.1.0 • Pub pubnub: < 4.3.0 → fixed in 4.3.0 • PyPI pubnub: < 7.3.0 → fixed in 7.3.0

Description

Versions of the package pubnub before 7.4.0; all versions of the package com.pubnub:pubnub; versions of the package pubnub before 6.19.0; all versions of the package github.com/pubnub/go; versions of the package github.com/pubnub/go/v7 before 7.2.0; versions of the package pubnub before 7.3.0; versions of the package pubnub/pubnub before 6.1.0; versions of the package pubnub before 5.3.0; versions of the package pubnub before 0.4.0; versions of the package pubnub/c-core before 4.5.0; versions of the package com.pubnub:pubnub-kotlin before 7.7.0; versions of the package pubnub/swift before 6.2.0; versions of the package pubnub before 5.2.0; versions of the package pubnub before 4.3.0 are vulnerable to Insufficient Entropy via the getKey function, due to inefficient implementation of the AES-256-CBC cryptographic algorithm. The provided encrypt function is less secure when hex encoding and trimming are applied, leaving half of the bits in the key always the same for every encoded message or file. Note: In order to exploit this vulnerability, the attacker needs to invest resources in preparing the attack and brute-force the encryption.

Related

Alias · CVE (1)

  • CVE-2023-26154 Versions of the package pubnub before 7.4.0; all versions of the package com.pubnub:pubnub; versions of the package pubnub before 6.19.0;… vulnerability

Weakness · CWE (1)

  • CWE-331 Insufficient Entropy weakness

References