GitHub Advisoryadvisory · Packagist

GHSA-585j-5449-mf5m Drupal cross-site scripting vulnerability

MEDIUM Published 2022-05-14 Modified 2024-04-23 Official page ↗
Aliases
CVE-2017-6927
Ecosystem
Packagist
Packages
drupal/core, drupal/drupal
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2024-04-23

Affected packages

• Packagist drupal/core: >= 8.4.0, < 8.4.5 → fixed in 8.4.5 • Packagist drupal/core: >= 7.0, < 7.57 → fixed in 7.57 • Packagist drupal/drupal: >= 8.4.0, < 8.4.5 → fixed in 8.4.5 • Packagist drupal/drupal: >= 7.0, < 7.57 → fixed in 7.57

Description

Drupal 8.4.x versions before 8.4.5 and Drupal 7.x versions before 7.57 has a Drupal.checkPlain() JavaScript function which is used to escape potentially dangerous text before outputting it to HTML (as JavaScript output does not typically go through Twig autoescaping). This function does not correctly handle all methods of injecting malicious HTML, leading to a cross-site scripting vulnerability under certain circumstances. The PHP functions which Drupal provides for HTML escaping are not affected.

Related

Alias · CVE (1)

  • CVE-2017-6927 Drupal 8.4.x versions before 8.4.5 and Drupal 7.x versions before 7.57 has a Drupal.checkPlain() JavaScript function which is used to… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References