GitHub Advisoryadvisory · Packagist
GHSA-5868-g58j-vrj5 phpMyAdmin Improper Privilege Management
CRITICAL
Official page ↗
- Aliases
- CVE-2017-18264
- Ecosystem
- Packagist
- Packages
- phpmyadmin/phpmyadmin
- Severity
- Critical
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-269
- Reviewed
- 2024-04-24
Affected packages
• Packagist phpmyadmin/phpmyadmin: >= 4.0, < 4.0.10.20 → fixed in 4.0.10.20
• Packagist phpmyadmin/phpmyadmin: >= 4.7.0-beta1, < 4.7.0 → fixed in 4.7.0
• Packagist phpmyadmin/phpmyadmin: >= 4.4.0, <= 4.4.15.10 (no fix yet)
• Packagist phpmyadmin/phpmyadmin: >= 4.6.0, <= 4.6.6 (no fix yet)
Description
An issue was discovered in libraries/common.inc.php in phpMyAdmin 4.0 before 4.0.10.20, 4.4.x, 4.6.x, and 4.7.0 prereleases. The restrictions caused by $cfg['Servers'][$i]['AllowNoPassword'] = false are bypassed under certain PHP versions (e.g., version 5). This can allow the login of users who have no password set even if the administrator has set $cfg['Servers'][$i]['AllowNoPassword'] to false (which is also the default). This occurs because some implementations of the PHP substr function return false when given '' as the first argument.
Related
Alias · CVE (1)
- CVE-2017-18264 An issue was discovered in libraries/common.inc.php in phpMyAdmin 4.0 before 4.0.10.20, 4.4.x, 4.6.x, and 4.7.0 prereleases. vulnerability
Weakness · CWE (1)
- CWE-269 Improper Privilege Management weakness