GitHub Advisoryadvisory · PyPI

GHSA-5889-7v45-q28m Incomplete validation in signal ops leads to crashes in TensorFlow

MEDIUM Published 2022-05-24 Modified 2022-06-08 Official page ↗
Aliases
CVE-2022-29213
Ecosystem
PyPI
Packages
tensorflow, tensorflow-cpu, tensorflow-gpu
Severity
Moderate
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-20, CWE-617
Reviewed
2022-05-24

Affected packages

• PyPI tensorflow: < 2.6.4 → fixed in 2.6.4 • PyPI tensorflow: >= 2.7.0, < 2.7.2 → fixed in 2.7.2 • PyPI tensorflow: >= 2.8.0, < 2.8.1 → fixed in 2.8.1 • PyPI tensorflow-cpu: < 2.6.4 → fixed in 2.6.4 • PyPI tensorflow-cpu: >= 2.7.0, < 2.7.2 → fixed in 2.7.2 • PyPI tensorflow-cpu: >= 2.8.0, < 2.8.1 → fixed in 2.8.1 • PyPI tensorflow-gpu: < 2.6.4 → fixed in 2.6.4 • PyPI tensorflow-gpu: >= 2.7.0, < 2.7.2 → fixed in 2.7.2 • PyPI tensorflow-gpu: >= 2.8.0, < 2.8.1 → fixed in 2.8.1

Description

Impact The `tf.compat.v1.signal.rfft2d` and `tf.compat.v1.signal.rfft3d` lack input validation and under certain condition can result in crashes (due to `CHECK`-failures). Patches We have patched the issue in GitHub commit 0a8a781e597b18ead006d19b7d23d0a369e9ad73 (merging GitHub PR #55274). The fix will be included in TensorFlow 2.9.0. We will also cherrypick this commit on TensorFlow 2.8.1, TensorFlow 2.7.2, and TensorFlow 2.6.4, as these are also affected and still in supported range. For more information Please consult our security guide for more information regarding the security model and how to contact us with issues and questions. Attribution This vulnerability has been reported externally via a GitHub issue.

Related

Alias · CVE (1)

  • CVE-2022-29213 TensorFlow is an open source platform for machine learning. vulnerability

Weakness · CWE (2)

  • CWE-20 Improper Input Validation weakness
  • CWE-617 Reachable Assertion weakness

References