GitHub Advisoryadvisory · PyPI

GHSA-588w-w6mv-3cw5 Ansible Insertion of Sensitive Information into Log File vulnerability

CRITICAL Published 2022-05-13 Modified 2024-09-04 Official page ↗
Aliases
CVE-2017-7550
Ecosystem
PyPI
Packages
ansible
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-532
Reviewed
2023-02-08

Affected packages

• PyPI ansible: >= 2.4.0.0, < 2.4.1.0 → fixed in 2.4.1.0 • PyPI ansible: >= 2.3.0.0, < 2.3.3.0 → fixed in 2.3.3.0

Description

A flaw was found in the way Ansible (2.3.x before 2.3.3, and 2.4.x before 2.4.1) passed certain parameters to the jenkins_plugin module. Remote attackers could use this flaw to expose sensitive information from a remote host's logs. This flaw was fixed by not allowing passwords to be specified in the "params" argument, and noting this in the module documentation.

Related

Alias · CVE (1)

  • CVE-2017-7550 A flaw was found in the way Ansible (2.3.x before 2.3.3, and 2.4.x before 2.4.1) passed certain parameters to the jenkins_plugin module. vulnerability

Weakness · CWE (1)

  • CWE-532 Insertion of Sensitive Information into Log File weakness

References