GitHub Advisoryadvisory · Packagist

GHSA-58mj-pw57-4vm2 Cross-site scripting in PHPMailer

MEDIUM Published 2020-03-05 Modified 2021-08-19 Official page ↗
Aliases
CVE-2017-11503
Ecosystem
Packagist
Packages
phpmailer/phpmailer
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2020-03-05

Affected packages

• Packagist phpmailer/phpmailer: >= 5.0.0, < 5.2.24 → fixed in 5.2.24

Description

PHPMailer versions prior to 5.2.24 (released July 26th 2017) have an XSS vulnerability in one of the code examples, CVE-2017-11503. The code_generator.phps example did not filter user input prior to output. This file is distributed with a `.phps` extension, so it it not normally executable unless it is explicitly renamed, and the file is not included when PHPMailer is loaded through composer, so it is safe by default. There was also an undisclosed potential XSS vulnerability in the default exception handler (unused by default). Patches for both issues kindly provided by Patrick Monnerat of the Fedora Project. Impact PHPMailer 5.2.23 has XSS in the &quot;From Email Address&quot; and &quot;To Email Address&quot; fields of code_generator.php. Patches Fixed in 5.2.24 Workarounds None. References https://nvd.nist.gov/vuln/detail/CVE-2017-11503 For more information If you have any questions or comments about this advisory: • Open a private issue in the PHPMailer project

Related

Alias · CVE (1)

  • CVE-2017-11503 PHPMailer 5.2.23 has XSS in the "From Email Address" and "To Email Address" fields of code_generator.php. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References