GitHub Advisoryadvisory · Go
GHSA-58w6-w55x-6wq8 Mattermost fails to validate user permissions in Boards
LOW
Official page ↗
- Aliases
- CVE-2025-13870
- Ecosystem
- Go
- Packages
- github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost
- Severity
- Low
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-284, CWE-306
- Reviewed
- 2025-12-03
Affected packages
• Go github.com/mattermost/mattermost/server/v8: < 8.0.0-20250905150616-ba86dfc5876b → fixed in 8.0.0-20250905150616-ba86dfc5876b
• Go github.com/mattermost/mattermost: >= 10.11.0, < 10.11.5 → fixed in 10.11.5
• Go github.com/mattermost/mattermost: >= 10.5.0, < 10.5.13 → fixed in 10.5.13
Description
Mattermost versions 10.11.x <= 10.11.4, 10.5.x <= 10.5.12 fail to validate the user permission when accessing the files and subscribing to the block in Boards, which allows an authenticated user to access other board files and was able to subscribe to the block from other boards that the user does not have access to
Related
Alias · CVE (1)
- CVE-2025-13870 Mattermost versions 10.11.x <= 10.11.4, 10.5.x <= 10.5.12 fail to validate the user permission when accessing the files and subscribing to… vulnerability