GitHub Advisoryadvisory · Maven

GHSA-59c9-pxq8-9c73 Improper JWT Signature Validation in SAP Security Services Library

CRITICAL Published 2023-12-13 Modified 2024-09-30 Official page ↗
Aliases
CVE-2023-50422
Ecosystem
Maven
Packages
com.sap.cloud.security:java-security, com.sap.cloud.security:spring-security, com.sap.cloud.security.xsuaa:spring-xsuaa
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-269
Reviewed
2023-12-13

Affected packages

• Maven com.sap.cloud.security:java-security: < 2.17.0 → fixed in 2.17.0 • Maven com.sap.cloud.security:java-security: >= 3.0.0, < 3.3.0 → fixed in 3.3.0 • Maven com.sap.cloud.security:spring-security: < 2.17.0 → fixed in 2.17.0 • Maven com.sap.cloud.security:spring-security: >= 3.0.0, < 3.3.0 → fixed in 3.3.0 • Maven com.sap.cloud.security.xsuaa:spring-xsuaa: < 2.17.0 → fixed in 2.17.0 • Maven com.sap.cloud.security.xsuaa:spring-xsuaa: >= 3.0.0, < 3.3.0 → fixed in 3.3.0

Description

Impact SAP BTP Security Services Integration Library ([Java] cloud-security-services-integration-library) allows under certain conditions an escalation of privileges. On successful exploitation, an unauthenticated attacker can obtain arbitrary permissions within the application. Patches Upgrade to patched version >= 2.17.0 or >= 3.3.0 We always recommend to upgrade to the latest released version. Workarounds No workarounds References https://www.cve.org/CVERecord?id=CVE-2023-50422

Related

Alias · CVE (1)

  • CVE-2023-50422 SAP BTP Security Services Integration Library ([Java] cloud-security-services-integration-library) - versions below 2.17.0 and versions… vulnerability

Weakness · CWE (1)

  • CWE-269 Improper Privilege Management weakness

References