GitHub Advisoryadvisory · RubyGems
GHSA-59gp-qqm7-cw4j Nokogiri has vulnerable dependencies on libxml2 and libxslt
HIGH
Official page ↗
- Aliases
- CVE-2021-30560
- Ecosystem
- RubyGems
- Packages
- nokogiri
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-416
- Reviewed
- 2023-06-23
Affected packages
• RubyGems nokogiri: < 1.13.2 → fixed in 1.13.2
Description
Use after free in Blink XSLT in Google Chrome prior to 91.0.4472.164 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.
Related
Alias · CVE (1)
- CVE-2021-30560 Use after free in Blink XSLT in Google Chrome prior to 91.0.4472.164 allowed a remote attacker to potentially exploit heap corruption via a… vulnerability
Weakness · CWE (1)
- CWE-416 Use After Free weakness
References
- https://github.com/sparklemotion/nokogiri/security/advisories/GHSA-fq42-c5rg-92c2 web
- https://nvd.nist.gov/vuln/detail/CVE-2021-30560 advisory
- https://chromereleases.googleblog.com/2021/07/stable-channel-update-for-desktop.html web
- https://crbug.com/1219209 web
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/nokogiri/CVE-2021-30560.yml web
- https://github.com/sparklemotion/nokogiri package
- https://github.com/sparklemotion/nokogiri/releases/tag/v1.13.2 web
- https://lists.debian.org/debian-lts-announce/2022/09/msg00010.html web
- https://security.gentoo.org/glsa/202310-23 web
- https://www.debian.org/security/2022/dsa-5216 web