GitHub Advisoryadvisory · Maven, PyPI

GHSA-59hw-j9g6-mfg3 Apache Spark UI vulnerable to Command Injection

HIGH Published 2023-05-02 Modified 2026-06-09 Official page ↗
Aliases
CVE-2023-32007
Ecosystem
Maven, PyPI
Packages
org.apache.spark:spark-parent_2.12, pyspark
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-77
Reviewed
2023-05-02

Affected packages

• Maven org.apache.spark:spark-parent_2.12: >= 3.1.1, < 3.2.2 → fixed in 3.2.2 • PyPI pyspark: >= 3.1.1, < 3.2.2 → fixed in 3.2.2

Description

The Apache Spark UI offers the possibility to enable ACLs via the configuration option spark.acls.enable. With an authentication filter, this checks whether a user has access permissions to view or modify the application. If ACLs are enabled, a code path in HttpSecurityFilter can allow someone to perform impersonation by providing an arbitrary user name. A malicious user might then be able to reach a permission check function that will ultimately build a Unix shell command based on their input, and execute it. This will result in arbitrary shell command execution as the user Spark is currently running as. This issue was disclosed earlier as CVE-2022-33891, but incorrectly claimed version 3.1.3 (which has since gone EOL) would not be affected. NOTE: This vulnerability only affects products that are no longer supported by the maintainer. Users are recommended to upgrade to a supported version of Apache Spark, such as version 3.4.0.

Related

Alias · CVE (1)

  • CVE-2023-32007 ** UNSUPPORTED WHEN ASSIGNED ** The Apache Spark UI offers the possibility to enable ACLs via the configuration option spark.acls.enable. vulnerability

Weakness · CWE (1)

  • CWE-77 Improper Neutralization of Special Elements used in a Command weakness

References