GitHub Advisoryadvisory · Packagist
GHSA-59pj-7mjh-4465 TYPO3 SQL Injection in low-level Query Generator
MEDIUM
Official page ↗
- Aliases
- CVE-2019-19850
- Ecosystem
- Packagist
- Packages
- typo3/cms, typo3/cms-core
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:L/A:N
- Reviewed
- 2024-04-25
Affected packages
• Packagist typo3/cms: >= 8.0, < 8.7.30 → fixed in 8.7.30
• Packagist typo3/cms: >= 9.0, < 9.5.12 → fixed in 9.5.12
• Packagist typo3/cms: >= 10.0, < 10.2.2 → fixed in 10.2.2
• Packagist typo3/cms-core: >= 8.0, < 8.7.30 → fixed in 8.7.30
• Packagist typo3/cms-core: >= 9.0, < 9.5.12 → fixed in 9.5.12
• Packagist typo3/cms-core: >= 10.0, < 10.2.2 → fixed in 10.2.2
Description
An issue was discovered in TYPO3 before 8.7.30, 9.x before 9.5.12, and 10.x before 10.2.2. Because escaping of user-submitted content is mishandled, the class QueryGenerator is vulnerable to SQL injection. Exploitation requires having the system extension ext:lowlevel installed, and a valid backend user who has administrator privileges.
Related
Alias · CVE (1)
- CVE-2019-19850 An issue was discovered in TYPO3 before 8.7.30, 9.x before 9.5.12, and 10.x before 10.2.2. vulnerability