GitHub Advisoryadvisory · Packagist

GHSA-59vf-hjxc-f9c5 Magento Open Source allows Cross-Site Scripting (XSS)

MEDIUM Published 2024-04-10 Modified 2025-03-04 Official page ↗
Aliases
CVE-2024-20759
Ecosystem
Packagist
Packages
magento/community-edition, magento/project-community-edition
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:N
Weaknesses
CWE-79
Reviewed
2025-03-04

Affected packages

• Packagist magento/community-edition: 2.4.6 (no fix yet) • Packagist magento/community-edition: 2.4.5 (no fix yet) • Packagist magento/community-edition: 2.4.4 (no fix yet) • Packagist magento/community-edition: >= 2.4.7-beta1, < 2.4.7 → fixed in 2.4.7 • Packagist magento/community-edition: >= 2.4.6-p1, < 2.4.6-p5 → fixed in 2.4.6-p5 • Packagist magento/community-edition: >= 2.4.5-p1, < 2.4.5-p7 → fixed in 2.4.5-p7 • Packagist magento/community-edition: >= 2.4.4-p1, < 2.4.4-p8 → fixed in 2.4.4-p8 • Packagist magento/project-community-edition: <= 2.0.2 (no fix yet)

Description

Adobe Commerce versions 2.4.6-p4, 2.4.5-p6, 2.4.4-p7, 2.4.7-beta3 and earlier are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by a high-privileged attacker to inject malicious scripts into vulnerable form fields. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field. Confidentiality and integrity are considered high due to having admin impact.

Related

Alias · CVE (1)

  • CVE-2024-20759 Adobe Commerce versions 2.4.6-p4, 2.4.5-p6, 2.4.4-p7, 2.4.7-beta3 and earlier are affected by a stored Cross-Site Scripting (XSS)… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References