GitHub Advisoryadvisory · Packagist

GHSA-5c58-w9xc-qcj9 Symfony Vulnerable to PHP Eval Injection

MEDIUM Published 2022-05-17 Modified 2024-04-25 Official page ↗
Aliases
CVE-2015-2308
Ecosystem
Packagist
Packages
symfony/symfony, symfony/http-kernel
Severity
Moderate
Weaknesses
CWE-94
Reviewed
2024-04-25

Affected packages

• Packagist symfony/symfony: >= 2.0.0, < 2.3.27 → fixed in 2.3.27 • Packagist symfony/symfony: >= 2.4.0, < 2.5.11 → fixed in 2.5.11 • Packagist symfony/symfony: >= 2.6.0, < 2.6.6 → fixed in 2.6.6 • Packagist symfony/http-kernel: >= 2.0.0, < 2.3.27 → fixed in 2.3.27 • Packagist symfony/http-kernel: >= 2.4.0, < 2.5.11 → fixed in 2.5.11 • Packagist symfony/http-kernel: >= 2.6.0, < 2.6.6 → fixed in 2.6.6

Description

Applications with ESI support (and SSI support as of Symfony 2.6) enabled and using the Symfony built-in reverse proxy (the `Symfony\Component\HttpKernel\HttpCache class) are vulnerable to PHP code injection; a malicious user can inject PHP code that will be executed by the server. HttpCache uses eval() to execute files in its cache when they contain ESI tags (and only when ESI is enabled). The vulnerability comes from the fact that PHP allows contents of tags to be executed (and this kind of PHP tags is always available regardless of the configuration), but there were not escaped before the evaluation. A possible exploit comes from websites also vulnerable to Cross-Site Scripting as an attacker can successfully conduct a PHP code injection attack by passing such a tag in a user submitted variable (for which proper output escaping was not applied).

Related

Alias · CVE (1)

  • CVE-2015-2308 Eval injection vulnerability in the HttpCache class in HttpKernel in Symfony 2.x before 2.3.27, 2.4.x and 2.5.x before 2.5.11, and 2.6.x… vulnerability

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References