GitHub Advisoryadvisory · Maven

GHSA-5c5p-jxvx-x7j2 Apache Tomcat vulnerable to Cross-site Scripting

LOW Published 2022-05-01 Modified 2024-02-14 Official page ↗
Aliases
CVE-2007-2450
Ecosystem
Maven
Packages
org.apache.tomcat:tomcat
Severity
Low
Weaknesses
CWE-79
Reviewed
2024-02-14

Affected packages

• Maven org.apache.tomcat:tomcat: >= 4.0.0, <= 4.0.6 (no fix yet) • Maven org.apache.tomcat:tomcat: >= 4.1.0, < 4.1.37 → fixed in 4.1.37 • Maven org.apache.tomcat:tomcat: >= 5.0.0, <= 5.0.30 (no fix yet) • Maven org.apache.tomcat:tomcat: >= 5.5.0, < 5.5.25 → fixed in 5.5.25 • Maven org.apache.tomcat:tomcat: >= 6.0.0, < 6.0.14 → fixed in 6.0.14

Description

Multiple cross-site scripting (XSS) vulnerabilities in the (1) Manager and (2) Host Manager web applications in Apache Tomcat 4.0.0 through 4.0.6, 4.1.0 through 4.1.36, 5.0.0 through 5.0.30, 5.5.0 through 5.5.24, and 6.0.0 through 6.0.13 allow remote authenticated users to inject arbitrary web script or HTML via a parameter name to manager/html/upload, and other unspecified vectors.

Related

Alias · CVE (1)

  • CVE-2007-2450 Multiple cross-site scripting (XSS) vulnerabilities in the (1) Manager and (2) Host Manager web applications in Apache Tomcat 4.0.0 through… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References