GitHub Advisoryadvisory · npm
GHSA-5c8j-xr24-2665 Potential Command Injection in printer
CRITICAL
Official page ↗
- Aliases
- CVE-2014-3741
- Ecosystem
- npm
- Packages
- printer
- Severity
- Critical
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-77
- Reviewed
- 2020-06-16
Affected packages
• npm printer: < 0.0.2 → fixed in 0.0.2
Description
Versions 0.0.1 and earlier of `printer` are affected by a command injection vulnerability resulting from a failure to sanitize command arguments properly in the `printDirect()` function.
Recommendation
Update to version 0.0.2 or later.
Related
Alias · CVE (1)
- CVE-2014-3741 The printDirect function in lib/printer.js in the node-printer module 0.0.1 and earlier for Node.js allows remote attackers to execute… vulnerability
Weakness · CWE (1)
- CWE-77 Improper Neutralization of Special Elements used in a Command weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2014-3741 advisory
- https://github.com/tojocky/node-printer/commit/e001e38738c17219a1d9dd8c31f7d82b9c0013c7 web
- https://github.com/advisories/GHSA-5c8j-xr24-2665 advisory
- https://github.com/tojocky/node-printer package
- https://www.npmjs.com/advisories/27 web
- http://www.openwall.com/lists/oss-security/2014/05/13/1 web
- http://www.openwall.com/lists/oss-security/2014/05/15/2 web