GitHub Advisoryadvisory · Maven

GHSA-5cf4-jqwp-584g Improper Privilege Management in org.apache.hadoop:hadoop-main

HIGH Published 2019-03-25 Modified 2022-09-17 Official page ↗
Aliases
CVE-2018-11767
Ecosystem
Maven
Packages
org.apache.hadoop:hadoop-main
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:H
Weaknesses
CWE-269
Reviewed
2020-06-16

Affected packages

• Maven org.apache.hadoop:hadoop-main: >= 2.7.5, < 2.7.7 → fixed in 2.7.7 • Maven org.apache.hadoop:hadoop-main: >= 2.8.3, < 2.8.5 → fixed in 2.8.5 • Maven org.apache.hadoop:hadoop-main: >= 2.9.0, < 2.9.2 → fixed in 2.9.2

Description

In Apache Hadoop 2.9.0 to 2.9.1, 2.8.3 to 2.8.4, 2.7.5 to 2.7.6, KMS blocking users or granting access to users incorrectly, if the system uses non-default groups mapping mechanisms.

Related

Alias · CVE (1)

  • CVE-2018-11767 In Apache Hadoop 2.9.0 to 2.9.1, 2.8.3 to 2.8.4, 2.7.5 to 2.7.6, KMS blocking users or granting access to users incorrectly, if the system… vulnerability

Weakness · CWE (1)

  • CWE-269 Improper Privilege Management weakness

References