GitHub Advisoryadvisory · Packagist
GHSA-5cjr-mxj5-wmrx SimpleSAMLphp has Possible DoS via XPath Transform
HIGH
Official page ↗
- Aliases
- CVE-2026-49289
- Ecosystem
- Packagist
- Packages
- simplesamlphp/saml2, simplesamlphp/saml2-legacy
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-400
- Reviewed
- 2026-07-02
Affected packages
• Packagist simplesamlphp/saml2: >= 4.20.0, < 4.20.3 → fixed in 4.20.3
• Packagist simplesamlphp/saml2-legacy: >= 4.20.0, < 4.20.3 → fixed in 4.20.3
• Packagist simplesamlphp/saml2: < 4.19.3 → fixed in 4.19.3
• Packagist simplesamlphp/saml2-legacy: < 4.19.3 → fixed in 4.19.3
Description
Summary
This library turned out to be vulnerable to Denial-of-Service attacks using XPath transforms. A mitigation has been put in place to restrict the number of transforms and to restrict transforms to only the transform-algorithms mentioned in the SAML 2.0 Core Specifications (and specifically refuse XPath transforms).
Impact
An attacker is able to send specially crafted messages to any entity relying on SimpleSAMLphp (or directly on this SAML2-library) to be able to perform a Denial-of-Service attack.
Related
Alias · CVE (1)
- CVE-2026-49289 The SimpleSAMLphp SAML2 library is a PHP library for SAML2 related functionality. vulnerability
Weakness · CWE (1)
- CWE-400 Uncontrolled Resource Consumption weakness