GitHub Advisoryadvisory · RubyGems

GHSA-5cqm-crxm-6qpv Buffer overrun in CGI.escape_html

CRITICAL Published 2021-12-14 Modified 2022-07-29 Official page ↗
Aliases
CVE-2021-41816
Ecosystem
RubyGems
Packages
cgi
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-190
Reviewed
2021-12-14

Affected packages

• RubyGems cgi: >= 0.3.0, < 0.3.1 → fixed in 0.3.1 • RubyGems cgi: >= 0.2.0, < 0.2.1 → fixed in 0.2.1 • RubyGems cgi: < 0.1.0.1 → fixed in 0.1.0.1

Description

A buffer overrun vulnerability was discovered in CGI.escape_html. This can lead to a buffer overflow when a user passes a very large string (> 700 MB) to CGI.escape_html on a platform where long type takes 4 bytes, typically, Windows.

Related

Alias · CVE (1)

  • CVE-2021-41816 CGI.escape_html in Ruby before 2.7.5 and 3.x before 3.0.3 has an integer overflow and resultant buffer overflow via a long string on… vulnerability

Weakness · CWE (1)

  • CWE-190 Integer Overflow or Wraparound weakness

References