GitHub Advisoryadvisory · Packagist

GHSA-5cvx-cwpx-9rjh Moodle Code Injection vulnerability

MEDIUM Published 2023-11-09 Modified 2023-11-10 Official page ↗
Aliases
CVE-2023-5550
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
Weaknesses
CWE-94
Reviewed
2023-11-10

Affected packages

• Packagist moodle/moodle: >= 4.3.0-beta, < 4.3.0-rc2 → fixed in 4.3.0-rc2 • Packagist moodle/moodle: >= 4.2.0, < 4.2.3 → fixed in 4.2.3 • Packagist moodle/moodle: >= 4.1.0, < 4.1.6 → fixed in 4.1.6 • Packagist moodle/moodle: >= 4.0.0, < 4.0.11 → fixed in 4.0.11 • Packagist moodle/moodle: >= 3.10.0, < 3.11.17 → fixed in 3.11.17 • Packagist moodle/moodle: < 3.9.24 → fixed in 3.9.24

Description

In a shared hosting environment that has been misconfigured to allow access to other users' content, a Moodle user who also has direct access to the web server outside of the Moodle webroot could utilise a local file include to achieve remote code execution.

Related

Alias · CVE (1)

  • CVE-2023-5550 In a shared hosting environment that has been misconfigured to allow access to other users' content, a Moodle user who also has direct… vulnerability

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References