GitHub Advisoryadvisory · PyPI

GHSA-5cx2-vq3h-x52c Apache superset missing check for default SECRET_KEY

HIGH Published 2023-04-24 Modified 2025-10-22 Official page ↗
Aliases
CVE-2023-27524
Ecosystem
PyPI
Packages
apache-superset
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:L/E:H
Weaknesses
CWE-1188
Reviewed
2023-04-24

Affected packages

• PyPI apache-superset: < 2.1.0 → fixed in 2.1.0

Description

Session Validation attacks in Apache Superset versions up to and including 2.0.1. Installations that have not altered the default configured SECRET_KEY according to installation instructions allow for an attacker to authenticate and access unauthorized resources. This does not affect Superset administrators who have changed the default value for SECRET_KEY config.

Related

Alias · CVE (1)

  • CVE-2023-27524 Session Validation attacks in Apache Superset versions up to and including 2.0.1. vulnerability

Weakness · CWE (1)

  • CWE-1188 Initialization of a Resource with an Insecure Default weakness

References