GitHub Advisoryadvisory · RubyGems

GHSA-5f2p-6vjv-2q2m Sup Code Injection vulnerability

MEDIUM Published 2022-05-17 Modified 2023-01-27 Official page ↗
Aliases
CVE-2013-4478
Ecosystem
RubyGems
Packages
sup
Severity
Moderate
Weaknesses
CWE-94
Reviewed
2023-01-27

Affected packages

• RubyGems sup: < 0.13.2.1 → fixed in 0.13.2.1 • RubyGems sup: >= 0.14.0, < 0.14.1.1 → fixed in 0.14.1.1

Description

Sup before 0.13.2.1 and 0.14.x before 0.14.1.1 allows remote attackers to execute arbitrary commands via shell metacharacters in the filename of an email attachment.

Related

Alias · CVE (1)

  • CVE-2013-4478 Sup before 0.13.2.1 and 0.14.x before 0.14.1.1 allows remote attackers to execute arbitrary commands via shell metacharacters in the… vulnerability

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References