GitHub Advisoryadvisory · Packagist

GHSA-5f37-gxvh-23v6 Remote code execution in PHPMailer

CRITICAL Published 2020-03-05 Modified 2025-10-22 Official page ↗
Aliases
CVE-2016-10033
Ecosystem
Packagist
Packages
phpmailer/phpmailer
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:H
Weaknesses
CWE-77, CWE-88
Reviewed
2020-03-05

Affected packages

• Packagist phpmailer/phpmailer: >= 5.0.0, < 5.2.18 → fixed in 5.2.18

Description

Impact The `mailSend` function in the default `isMail` transport in PHPMailer before 5.2.18 might allow remote attackers to pass extra parameters to the mail command and consequently execute arbitrary code via a \&quot; (backslash double quote) in a crafted `Sender` property. Patches Fixed in 5.2.18 Workarounds Filter and validate user input before passing it to internal functions. References https://nvd.nist.gov/vuln/detail/CVE-2016-10033 Related to a follow-on issue in https://nvd.nist.gov/vuln/detail/CVE-2016-10045 For more information If you have any questions or comments about this advisory: • Open a private issue in the PHPMailer project

Related

Alias · CVE (1)

  • CVE-2016-10033 The mailSend function in the isMail transport in PHPMailer before 5.2.18 might allow remote attackers to pass extra parameters to the mail… vulnerability

Weakness · CWE (2)

  • CWE-77 Improper Neutralization of Special Elements used in a Command weakness
  • CWE-88 Improper Neutralization of Argument Delimiters in a Command weakness

References