GitHub Advisoryadvisory · Go
GHSA-5ffw-gxpp-mxpf containerd CRI plugin: Host memory exhaustion through ExecSync
MEDIUM
Official page ↗
- Aliases
- CVE-2022-31030
- Ecosystem
- Go
- Packages
- github.com/containerd/containerd
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-400
- Reviewed
- 2022-06-06
Affected packages
• Go github.com/containerd/containerd: < 1.5.13 → fixed in 1.5.13
• Go github.com/containerd/containerd: >= 1.6.0, < 1.6.6 → fixed in 1.6.6
Description
Impact
A bug was found in containerd's CRI implementation where programs inside a container can cause the containerd daemon to consume memory without bound during invocation of the `ExecSync` API. This can cause containerd to consume all available memory on the computer, denying service to other legitimate workloads. Kubernetes and crictl can both be configured to use containerd's CRI implementation; `ExecSync` may be used when running probes or when executing processes via an "exec" facility.
Patches
This bug has been fixed in containerd 1.6.6 and 1.5.13. Users should update to these versions to resolve the issue.
Workarounds
Ensure that only trusted images and commands are used.
References
• Similar fix in cri-o's CRI implementation https://github.com/cri-o/cri-o/security/advisories/GHSA-fcm2-6c3h-pg6j
Credits
The containerd project would like to thank David Korczynski and Adam Korczynski of ADA Logics for responsibly disclosing this issue in accordance with the containerd security policy during a security audit sponsored by CNCF and facilitated by OSTIF.
For more information
If you have any questions or comments about this advisory:
• Open an issue in containerd
• Email us at [email protected]
Related
Alias · CVE (1)
- CVE-2022-31030 containerd is an open source container runtime. vulnerability
Weakness · CWE (1)
- CWE-400 Uncontrolled Resource Consumption weakness
References
- https://github.com/containerd/containerd/security/advisories/GHSA-5ffw-gxpp-mxpf web
- https://nvd.nist.gov/vuln/detail/CVE-2022-31030 advisory
- https://github.com/containerd/containerd/commit/c1bcabb4541930f643aa36a2b38655e131346382 web
- https://github.com/containerd/containerd package
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/REOZCUAPCA7NFDWYBDYX6EYXWLHABKBO web
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WSIGDBHAB3I75JBJNGWEPBTJPS2FOVHD web
- https://lists.fedoraproject.org/archives/list/[email protected]/message/REOZCUAPCA7NFDWYBDYX6EYXWLHABKBO web
- https://lists.fedoraproject.org/archives/list/[email protected]/message/WSIGDBHAB3I75JBJNGWEPBTJPS2FOVHD web
- https://security.gentoo.org/glsa/202401-31 web
- https://www.debian.org/security/2022/dsa-5162 web
- http://www.openwall.com/lists/oss-security/2022/06/07/1 web