GitHub Advisoryadvisory · Packagist
GHSA-5fgv-cvr8-xg48 Moodle vulnerable to Cross-site Scripting
LOW
Official page ↗
- Aliases
- CVE-2010-1614
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- Low
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:U
- Weaknesses
- CWE-79
- Reviewed
- 2025-04-11
Affected packages
• Packagist moodle/moodle: >= 1.8.0, < 1.8.12 → fixed in 1.8.12
• Packagist moodle/moodle: >= 1.9.0, < 1.9.8 → fixed in 1.9.8
Description
Multiple cross-site scripting (XSS) vulnerabilities in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8 allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) the Login-As feature or (2) when the global search feature is enabled, unspecified global search forms in the Global Search Engine. NOTE: vector 1 might be resultant from a cross-site request forgery (CSRF) vulnerability.
Related
Alias · CVE (1)
- CVE-2010-1614 Multiple cross-site scripting (XSS) vulnerabilities in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8 allow remote attackers to inject… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness