GitHub Advisoryadvisory · Packagist
GHSA-5fj7-f8x3-q2mc simpleSAMLphp incorrectly handles XML encryption
HIGH
Official page ↗
- Aliases
- CVE-2011-4625
- Ecosystem
- Packagist
- Packages
- simplesamlphp/simplesamlphp
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-755
- Reviewed
- 2024-01-12
Affected packages
• Packagist simplesamlphp/simplesamlphp: < 1.8.1 → fixed in 1.8.1
Description
simplesamlphp before 1.6.3 (squeeze) and before 1.8.2 (sid) incorrectly handles XML encryption which could allow remote attackers to decrypt or forge messages.
Related
Alias · CVE (1)
- CVE-2011-4625 simplesamlphp before 1.6.3 (squeeze) and before 1.8.2 (sid) incorrectly handles XML encryption which could allow remote attackers to… vulnerability
Weakness · CWE (1)
- CWE-755 Improper Handling of Exceptional Conditions weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2011-4625 advisory
- https://github.com/simplesamlphp/simplesamlphp package
- https://github.com/simplesamlphp/simplesamlphp/blob/b3059c51a915910c6631fb2ee597c0fb6ad9162b/docs/simplesamlphp-changelog-1.x.md?plain=1#L1624 web
- https://secure1.securityspace.com/smysecure/catid.html?in=DSA%202330-1 web
- https://security-tracker.debian.org/tracker/CVE-2011-4625 web
- https://www.mageni.net/vulnerability/debian-security-advisory-dsa-2330-1-simplesamlphp-70545 web