GitHub Advisoryadvisory · Packagist
GHSA-5gx6-f2qq-475f EGroupware Code Injection vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2010-3313
- Ecosystem
- Packagist
- Packages
- egroupware/egroupware
- Severity
- High
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P
- Weaknesses
- CWE-94
- Reviewed
- 2025-04-12
Affected packages
• Packagist egroupware/egroupware: < 1.6.003 → fixed in 1.6.003
• Packagist egroupware/egroupware: >= 9.1, < 9.1.20100309 → fixed in 9.1.20100309
• Packagist egroupware/egroupware: >= 9.2, < 9.2.20100309 → fixed in 9.2.20100309
Description
`phpgwapi/js/fckeditor/editor/dialog/fck_spellerpages/spellerpages/serverscripts/spellchecker.php` in EGroupware 1.4.001+.002; 1.6.001+.002 and possibly other versions before 1.6.003; and EPL 9.1 before 9.1.20100309 and 9.2 before 9.2.20100309; allows remote attackers to execute arbitrary commands via shell metacharacters in the (1) aspell_path or (2) spellchecker_lang parameters.
Related
Alias · CVE (1)
- CVE-2010-3313 phpgwapi/js/fckeditor/editor/dialog/fck_spellerpages/spellerpages/serverscripts/spellchecker.php in EGroupware 1.4.001+.002; 1.6.001+.002… vulnerability
Weakness · CWE (1)
- CWE-94 Improper Control of Generation of Code weakness