GitHub Advisoryadvisory · RubyGems

GHSA-5h5r-ffc4-c455 strong_password Ruby gem malicious version causing Remote Code Execution vulnerability

CRITICAL Published 2019-07-08 Modified 2023-03-06 Official page ↗
Aliases
CVE-2019-13354
Ecosystem
RubyGems
Packages
strong_password
Severity
Critical
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-94
Reviewed
2019-07-08

Affected packages

• RubyGems strong_password: >= 0.0.7, < 0.0.8 → fixed in 0.0.8

Description

The strong_password gem 0.0.7 for Ruby, as distributed on RubyGems.org, included a code-execution backdoor inserted by a third party. Version 0.0.8 does not contain the backdoor.

Related

Alias · CVE (1)

  • CVE-2019-13354 The strong_password gem 0.0.7 for Ruby, as distributed on RubyGems.org, included a code-execution backdoor inserted by a third party. vulnerability

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References