GitHub Advisoryadvisory · npm
GHSA-5h7x-68wj-jhwc Docsify vulnerable to cross-site scripting due to mishandled encoding
MEDIUM
Official page ↗
- Aliases
- CVE-2021-30074
- Ecosystem
- npm
- Packages
- docsify
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2023-10-19
Affected packages
• npm docsify: < 4.12.2 → fixed in 4.12.2
Description
docsify versions 4.12.1 and earlier are vulnerable to cross-site scripting (XSS) because the search component does not appropriately encode Code Blocks and mishandles the `"` character.
Related
Alias · CVE (1)
- CVE-2021-30074 docsify 4.12.1 is affected by Cross Site Scripting (XSS) because the search component does not appropriately encode Code Blocks and… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness