GitHub Advisoryadvisory · Packagist
GHSA-5hfj-r725-wpc4 october/system arbitrary code execution
HIGH
Official page ↗
- Aliases
- CVE-2021-32650
- Ecosystem
- Packagist
- Packages
- october/system
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-74, CWE-94
- Reviewed
- 2022-01-14
Affected packages
• Packagist october/system: >= 1.1.0, < 1.1.6 → fixed in 1.1.6
• Packagist october/system: < 1.0.473 → fixed in 1.0.473
Description
Impact
Assuming an attacker with access to the backend is able to execute PHP code by using the theme import feature. This will bypass the safe mode feature that prevents PHP execution in the CMS templates.
Patches
Issue has been patched in Build 473 and v1.1.6
Workarounds
Apply https://github.com/octobercms/october/commit/167b592eed291ae1563c8fcc5b9b34a03a300f26 to your installation manually if you are unable to upgrade.
References
Credits to:
• Sushi Yushi
For more information
If you have any questions or comments about this advisory:
• Email us at [email protected]
Related
Alias · CVE (1)
- CVE-2021-32650 October CMS is a self-hosted content management system (CMS) platform based on the Laravel PHP Framework. vulnerability