GitHub Advisoryadvisory · npm

GHSA-5hq7-j5wq-p227 feathers-sequelize vulnerable to SQL injection due to improper parameter filtering

CRITICAL Published 2022-10-26 Modified 2022-10-31 Official page ↗
Aliases
CVE-2022-29822
Ecosystem
npm
Packages
feathers-sequelize
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-89
Reviewed
2022-10-31

Affected packages

• npm feathers-sequelize: >= 6.0.0, < 6.3.4 → fixed in 6.3.4

Description

feathers-sequelize is vulnerable to improper parameter filtering in the Feathers js library, which may ultimately lead to SQL injection.

Related

Alias · CVE (1)

  • CVE-2022-29822 Due to improper parameter filtering in the Feathers js library, which may ultimately lead to SQL injection vulnerability

Weakness · CWE (1)

  • CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness

References