GitHub Advisoryadvisory · PyPI
GHSA-5hq9-5r78-2gjh LlamaIndex vulnerable to data loss through hash collisions in its DocugamiReader class
MEDIUM
Official page ↗
- Aliases
- CVE-2025-6211
- Ecosystem
- PyPI
- Packages
- llama-index, llama-index-readers-docugami
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
- Weaknesses
- CWE-440
- Reviewed
- 2025-07-10
Affected packages
• PyPI llama-index: < 0.12.41 → fixed in 0.12.41
• PyPI llama-index-readers-docugami: < 0.3.1 → fixed in 0.3.1
Description
A vulnerability in the DocugamiReader class of the run-llama/llama_index repository, up to but excluding version 0.12.41, involves the use of MD5 hashing to generate IDs for document chunks. This approach leads to hash collisions when structurally distinct chunks contain identical text, resulting in one chunk overwriting another. This can cause loss of semantically or legally important document content, breakage of parent-child chunk hierarchies, and inaccurate or hallucinated responses in AI outputs. The issue is resolved in version 0.3.1.
Related
Alias · CVE (1)
- CVE-2025-6211 A vulnerability in the DocugamiReader class of the run-llama/llama_index repository, up to version 0.12.28, involves the use of MD5 hashing… vulnerability
Weakness · CWE (1)
- CWE-440 Expected Behavior Violation weakness