GitHub Advisoryadvisory · Packagist
GHSA-5j2g-3ph4-rgvm Fix for authenticated remote code execution through layout update
HIGH
Official page ↗
- Aliases
- CVE-2021-41144
- Ecosystem
- Packagist
- Packages
- openmage/magento-lts
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-77
- Reviewed
- 2023-01-27
Affected packages
• Packagist openmage/magento-lts: < 19.4.22 → fixed in 19.4.22
• Packagist openmage/magento-lts: >= 20.0.0, < 20.0.19 → fixed in 20.0.19
Description
Impact
A layout block was able to bypass the block blacklist to execute remote code.
Related
Alias · CVE (1)
- CVE-2021-41144 OpenMage LTS is an e-commerce platform. vulnerability
Weakness · CWE (1)
- CWE-77 Improper Neutralization of Special Elements used in a Command weakness
References
- https://github.com/OpenMage/magento-lts/security/advisories/GHSA-5j2g-3ph4-rgvm web
- https://nvd.nist.gov/vuln/detail/CVE-2021-41144 advisory
- https://github.com/OpenMage/magento-lts/commit/06c45940ba3256cdfc9feea12a3c0ca56d23acf8 web
- https://github.com/OpenMage/magento-lts package
- https://github.com/OpenMage/magento-lts/releases/tag/v19.4.22 web
- https://github.com/OpenMage/magento-lts/releases/tag/v20.0.19 web