GitHub Advisoryadvisory · Maven
GHSA-5j46-5hwq-gwh7 Jenkins Cross-site Scripting vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2023-43495
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.main:jenkins-core
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-79
- Reviewed
- 2023-09-21
Affected packages
• Maven org.jenkins-ci.main:jenkins-core: >= 2.50, < 2.414.2 → fixed in 2.414.2
• Maven org.jenkins-ci.main:jenkins-core: >= 2.415, < 2.424 → fixed in 2.424
Description
`ExpandableDetailsNote` allows annotating build log content with additional information that can be revealed when interacted with.
Jenkins 2.423 and earlier, LTS 2.414.1 and earlier does not escape the value of the `caption` constructor parameter of `ExpandableDetailsNote`.
This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to provide `caption` parameter values.
As of publication, the related API is not used within Jenkins (core), and the Jenkins security team is not aware of any affected plugins.
Jenkins 2.424, LTS 2.414.2 escapes `caption` constructor parameter values.
Related
Alias · CVE (1)
- CVE-2023-43495 Jenkins 2.423 and earlier, LTS 2.414.1 and earlier does not escape the value of the 'caption' constructor parameter of… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness