GitHub Advisoryadvisory · RubyGems
GHSA-5jcf-c5rg-rmm8 paperclip Server-Side Request Forgery vulnerability
CRITICAL
Official page ↗
- Aliases
- CVE-2017-0889
- Ecosystem
- RubyGems
- Packages
- paperclip
- Severity
- Critical
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-918
- Reviewed
- 2020-06-16
Affected packages
• RubyGems paperclip: >= 3.1.4, < 5.2.0 → fixed in 5.2.0
Description
Paperclip ruby gem version 3.1.4 and later suffers from a Server-SIde Request Forgery (SSRF) vulnerability in the `Paperclip::UriAdapter` class. Attackers may be able to access information about internal network resources.
Related
Alias · CVE (1)
- CVE-2017-0889 Paperclip ruby gem version 3.1.4 and later suffers from a Server-SIde Request Forgery (SSRF) vulnerability in the Paperclip::UriAdapter… vulnerability
Weakness · CWE (1)
- CWE-918 Server-Side Request Forgery weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-0889 advisory
- https://github.com/thoughtbot/paperclip/pull/2435 web
- https://hackerone.com/reports/209430 web
- https://hackerone.com/reports/713 web
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/paperclip/CVE-2017-0889.yml web
- https://github.com/thoughtbot/paperclip package