GitHub Advisoryadvisory · Packagist
GHSA-5jg5-xqfw-rv92 Microweber has a Cross-site Scripting vulnerability
LOW
Official page ↗
- Aliases
- CVE-2025-70791
- Ecosystem
- Packagist
- Packages
- microweber/microweber
- Severity
- Low
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2026-02-05
Affected packages
• Packagist microweber/microweber: < 2.0.20 → fixed in 2.0.20
Description
Cross-site Scripting vulnerability in the "/admin/order/abandoned" endpoint of Microweber 2.0.19. An attacker can manipulate the "orderDirection" parameter in a crafted URL and lure a user with admin privileges into visiting it, achieving JavaScript code execution in the victim's browser. The issue was reported to the developers and fixed in version 2.0.20.
Related
Alias · CVE (1)
- CVE-2025-70791 Cross Site Scripting vulnerability in the "/admin/order/abandoned" endpoint of Microweber 2.0.19. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness