GitHub Advisoryadvisory · Packagist

GHSA-5m55-g8pv-x8ww Magento stored Cross-Site Scripting (XSS) vulnerability

MEDIUM Published 2022-08-17 Modified 2024-01-11 Official page ↗
Aliases
CVE-2022-34258
Ecosystem
Packagist
Packages
magento/community-edition
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2024-01-11

Affected packages

• Packagist magento/community-edition: >= 2.3.0, < 2.3.7-p4 → fixed in 2.3.7-p4 • Packagist magento/community-edition: >= 2.4.4, < 2.4.5 → fixed in 2.4.5 • Packagist magento/community-edition: >= 2.4.0, < 2.4.3-p3 → fixed in 2.4.3-p3

Description

Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by an attacker with admin privileges to inject malicious scripts into vulnerable form fields. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field.

Related

Alias · CVE (1)

  • CVE-2022-34258 Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by a stored Cross-Site… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References