GitHub Advisoryadvisory · Maven

GHSA-5m62-pw8w-7w9f Apache Tomcat - Security constraints not correctly applied

CRITICAL Published 2026-05-12 Modified 2026-05-19 Official page ↗
Aliases
CVE-2026-43515
Ecosystem
Maven
Packages
org.apache.tomcat.embed:tomcat-embed-core, org.apache.tomcat:tomcat, org.apache.tomcat:tomcat-catalina
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-285
Reviewed
2026-05-19

Affected packages

• Maven org.apache.tomcat.embed:tomcat-embed-core: < 9.0.118 → fixed in 9.0.118 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 10.1.0-M1, < 10.1.55 → fixed in 10.1.55 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 11.0.0-M1, < 11.0.22 → fixed in 11.0.22 • Maven org.apache.tomcat:tomcat: < 9.0.118 → fixed in 9.0.118 • Maven org.apache.tomcat:tomcat: >= 10.1.0-M1, < 10.1.55 → fixed in 10.1.55 • Maven org.apache.tomcat:tomcat: >= 11.0.0-M1, < 11.0.22 → fixed in 11.0.22 • Maven org.apache.tomcat:tomcat-catalina: < 9.0.118 → fixed in 9.0.118 • Maven org.apache.tomcat:tomcat-catalina: >= 10.1.0-M1, < 10.1.55 → fixed in 10.1.55 • Maven org.apache.tomcat:tomcat-catalina: >= 11.0.0-M1, < 11.0.22 → fixed in 11.0.22

Description

Versions Affected: Apache Tomcat 11.0.0-M1 to 11.0.21 Apache Tomcat 10.1.0-M1 to 10.1.54 Apache Tomcat 9.0.0.M1 to 9.0.117 Older, unsupported versions may also be affected Description: When multiple security constraints defined an HTTP method constraint for the same extension pattern, only the first method constraint was applied. Mitigation: Users of the affected versions should apply one of the following mitigations: • Upgrade to Apache Tomcat 11.0.22 or later • Upgrade to Apache Tomcat 10.1.55 or later • Upgrade to Apache Tomcat 9.0.118 or later

Related

Alias · CVE (1)

  • CVE-2026-43515 Improper Authorization vulnerability when multiple method constraints define an HTTP method for the same extension in Apache Tomcat. vulnerability

Weakness · CWE (1)

  • CWE-285 Improper Authorization weakness

References