GitHub Advisoryadvisory · PyPI
GHSA-5mc5-5j6c-qmf9 cfscrape Improper Input Validation vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2017-7235
- Ecosystem
- PyPI
- Packages
- cfscrape
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-20
- Reviewed
- 2020-06-16
Affected packages
• PyPI cfscrape: >= 1.6.6, < 1.8.0 → fixed in 1.8.0
Description
An issue was discovered in cloudflare-scrape 1.6.6 through 1.7.1. A malicious website owner could craft a page that executes arbitrary Python code against any cfscrape user who scrapes that website. This is fixed in 1.8.0.
Related
Alias · CVE (1)
- CVE-2017-7235 An issue was discovered in cloudflare-scrape 1.6.6 through 1.7.1. vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-7235 advisory
- https://github.com/Anorov/cloudflare-scrape/issues/97 web
- https://github.com/Anorov/cloudflare-scrape package
- https://github.com/Anorov/cloudflare-scrape/releases/tag/1.8.0 web
- https://github.com/advisories/GHSA-5mc5-5j6c-qmf9 advisory
- https://github.com/pypa/advisory-database/tree/main/vulns/cfscrape/PYSEC-2017-7.yaml web
- https://web.archive.org/web/20170701161512/http://www.securityfocus.com/bid/97191 web