GitHub Advisoryadvisory · Maven

GHSA-5mp6-jrq3-r938 Apache Tomcat: LockOutRealm treats user names as case-sensitive

HIGH Published 2026-05-12 Modified 2026-05-18 Official page ↗
Aliases
CVE-2026-43513
Ecosystem
Maven
Packages
org.apache.tomcat.embed:tomcat-embed-core, org.apache.tomcat:tomcat, org.apache.tomcat:tomcat-catalina
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-178
Reviewed
2026-05-18

Affected packages

• Maven org.apache.tomcat.embed:tomcat-embed-core: < 9.0.118 → fixed in 9.0.118 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 10.1.0-M1, < 10.1.55 → fixed in 10.1.55 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 11.0.0-M1, < 11.0.22 → fixed in 11.0.22 • Maven org.apache.tomcat:tomcat: < 9.0.118 → fixed in 9.0.118 • Maven org.apache.tomcat:tomcat: >= 10.1.0-M1, < 10.1.55 → fixed in 10.1.55 • Maven org.apache.tomcat:tomcat: >= 11.0.0-M1, < 11.0.22 → fixed in 11.0.22 • Maven org.apache.tomcat:tomcat-catalina: < 9.0.118 → fixed in 9.0.118 • Maven org.apache.tomcat:tomcat-catalina: >= 10.1.0-M1, < 10.1.55 → fixed in 10.1.55 • Maven org.apache.tomcat:tomcat-catalina: >= 11.0.0-M1, < 11.0.22 → fixed in 11.0.22

Description

Improper Handling of Case Sensitivity vulnerability in LockOutRealm in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.21, from 10.1.0-M1 through 10.1.54, from 9.0.0.M1 through 9.0.117, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Older unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.22, 10.1.55 or 9.0.118 which fix the issue.

Related

Alias · CVE (1)

  • CVE-2026-43513 Improper Handling of Case Sensitivity vulnerability in LockOutRealm in Apache Tomcat. vulnerability

Weakness · CWE (1)

  • CWE-178 Improper Handling of Case Sensitivity weakness

References