GitHub Advisoryadvisory · Maven

GHSA-5mwr-jg3r-jv66 Jenkins allows Cross-Site Scripting (XSS)

LOW Published 2022-05-13 Modified 2025-03-13 Official page ↗
Aliases
CVE-2015-5326
Ecosystem
Maven
Packages
org.jenkins-ci.main:jenkins-core
Severity
Low
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N
Weaknesses
CWE-79
Reviewed
2025-03-13

Affected packages

• Maven org.jenkins-ci.main:jenkins-core: < 1.625.2 → fixed in 1.625.2 • Maven org.jenkins-ci.main:jenkins-core: >= 1.626, < 1.638 → fixed in 1.638

Description

Cross-site scripting (XSS) vulnerability in the slave overview page in Jenkins before 1.638 and LTS before 1.625.2 allows remote authenticated users with certain permissions to inject arbitrary web script or HTML via the slave offline status message.

Related

Alias · CVE (1)

  • CVE-2015-5326 Cross-site scripting (XSS) vulnerability in the slave overview page in Jenkins before 1.638 and LTS before 1.625.2 allows remote… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References