GitHub Advisoryadvisory · npm

GHSA-5p5w-j3g7-w4wv Authentication bypass via incorrect XML canonicalization and DOM traversal in saml2-js

MEDIUM Published 2019-07-05 Modified 2021-06-11 Official page ↗
Aliases
CVE-2017-11429
Ecosystem
npm
Packages
saml2-js
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
Weaknesses
CWE-287
Reviewed
2020-06-16

Affected packages

• npm saml2-js: < 1.12.4 → fixed in 1.12.4 • npm saml2-js: >= 2.0.0, < 2.0.2 → fixed in 2.0.2

Description

Versions of `saml2-js` prior to 1.12.4 or 2.0.2 are vulnerable to authentication bypass. The `saml2-js` library may incorrectly utilize the results of XML DOM traversal and canonicalization APIs in such a way that an attacker may be able to manipulate the SAML data without invalidating the cryptographic signature, allowing the attack to potentially bypass authentication to SAML service providers. Security Assertion Markup Language (SAML) is an XML-based markup language for security assertions regarding authentication and permissions, most commonly used for single sign-on (SSO) services. Some XML DOM traversal and canonicalization APIs may be inconsistent in handling of comments within XML nodes. Incorrect use of these APIs by some SAML libraries results in incorrect parsing of the inner text of XML nodes such that any inner text after the comment is lost prior to cryptographically signing the SAML message. Text after the comment therefore has no impact on the signature on the SAML message. A remote attacker can modify SAML content for a SAML service provider without invalidating the cryptographic signature, which may allow attackers to bypass primary authentication for the affected SAML service provider Recommendation If you use 1.x upgrade to version 1.12.4 or greater If you use 2.x upgrade to version 2.02 or greater

Related

Alias · CVE (1)

  • CVE-2017-11429 Clever saml2-js 2.0 and earlier may incorrectly utilize the results of XML DOM traversal and canonicalization APIs in such a way that an… vulnerability

Weakness · CWE (1)

  • CWE-287 Improper Authentication weakness

References