GitHub Advisoryadvisory · Packagist
GHSA-5p69-rmx8-7gw7 phpMyAdmin Multiple XSS Vulnerabilities
LOW
Official page ↗
- Aliases
- CVE-2011-3592
- Ecosystem
- Packagist
- Packages
- phpmyadmin/phpmyadmin
- Severity
- Low
- Weaknesses
- CWE-79
- Reviewed
- 2024-01-15
Affected packages
• Packagist phpmyadmin/phpmyadmin: >= 3.4.0, < 3.4.5 → fixed in 3.4.5
Description
Multiple cross-site scripting (XSS) vulnerabilities in the `PMA_unInlineEditRow` function in js/sql.js in phpMyAdmin 3.4.x before 3.4.5 allow remote authenticated users to inject arbitrary web script or HTML via a (1) database name, (2) table name, or (3) column name that is not properly handled after an inline-editing operation.
Related
Alias · CVE (1)
- CVE-2011-3592 Multiple cross-site scripting (XSS) vulnerabilities in the PMA_unInlineEditRow function in js/sql.js in phpMyAdmin 3.4.x before 3.4.5 allow… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2011-3592 advisory
- https://github.com/phpmyadmin/phpmyadmin/commit/2f28ce9c800274190418da0945ce3647d36e1db6 web
- https://github.com/phpmyadmin/phpmyadmin/commit/bda213c58aec44925be661acb0e76c19483ea170 web
- https://bugzilla.redhat.com/show_bug.cgi?id=738681 web
- https://github.com/phpmyadmin/composer package
- http://www.openwall.com/lists/oss-security/2011/09/30/8 web
- http://www.phpmyadmin.net/home_page/security/PMASA-2011-14.php web