GitHub Advisoryadvisory · PyPI
GHSA-5pcx-vqjp-p34w Cross-site Scripting in shuup
MEDIUM
Official page ↗
- Aliases
- CVE-2021-25963
- Ecosystem
- PyPI
- Packages
- shuup
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2021-10-01
Affected packages
• PyPI shuup: >= 1.6.0, < 2.11.0 → fixed in 2.11.0
Description
In Shuup, versions 1.6.0 through 2.10.8 are vulnerable to reflected Cross-Site Scripting (XSS) that allows execution of arbitrary javascript code on a victim browser. This vulnerability exists due to the error page contents not escaped.
Related
Alias · CVE (1)
- CVE-2021-25963 In Shuup, versions 1.6.0 through 2.10.8 are vulnerable to reflected Cross-Site Scripting (XSS) that allows execution of arbitrary… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2021-25963 advisory
- https://github.com/shuup/shuup/commit/75714c37e32796eb7cbb0d977af5bcaa26573588 web
- https://github.com/pypa/advisory-database/tree/main/vulns/shuup/PYSEC-2021-350.yaml web
- https://github.com/shuup/shuup package
- https://www.whitesourcesoftware.com/vulnerability-database/CVE-2021-25963 web