GitHub Advisoryadvisory · Packagist
GHSA-5pq5-9phv-q5j3 CardGate Payments plugin for WooCommerce does not validate request origin
HIGH
Official page ↗
- Aliases
- CVE-2020-8819
- Ecosystem
- Packagist
- Packages
- cardgate/woocommerce
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- Weaknesses
- CWE-346
- Reviewed
- 2023-07-12
Affected packages
• Packagist cardgate/woocommerce: < 3.1.16 → fixed in 3.1.16
Description
An issue was discovered in the CardGate Payments plugin through 3.1.15 for WooCommerce. Lack of origin authentication in the IPN callback processing function in cardgate/cardgate.php allows an attacker to remotely replace critical plugin settings (merchant ID, secret key, etc.) and therefore bypass the payment process (e.g., spoof an order status by manually sending an IPN callback request with a valid signature but without real payment) and/or receive all of the subsequent payments.
Related
Alias · CVE (1)
- CVE-2020-8819 An issue was discovered in the CardGate Payments plugin through 3.1.15 for WooCommerce. vulnerability
Weakness · CWE (1)
- CWE-346 Origin Validation Error weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2020-8819 advisory
- https://github.com/cardgate/woocommerce/issues/18 web
- https://github.com/cardgate/woocommerce/pull/17/commits/0b83588d604c8c56c7fded43144fcced96b2ada9 web
- https://github.com/cardgate/woocommerce web
- https://github.com/cardgate/woocommerce/blob/f2111af7b1a3fd701c1c5916137f3ac09482feeb/cardgate/cardgate.php#L426-L442 web
- https://wpvulndb.com/vulnerabilities/10097 web
- https://www.exploit-db.com/exploits/48134 web
- http://packetstormsecurity.com/files/156504/WordPress-WooCommerce-CardGate-Payment-Gateway-3.1.15-Bypass.html web